In short
- CVE-2019-18954 is a MEDIUM (CVSS 5.3) vulnerability affecting pomelo (netease), pomelo.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.1% of all vulnerabilities.
- Fix: update to 2.2.7 or later.
| Package | Affected versions | Patched versions |
|---|
| pomelo | = 2.2.5
| No fix yet |
| pomelo npm | < 2.2.7
| 2.2.7
|
Description
Pomelo v2.2.5 allows external control of critical state data. A malicious user input can corrupt arbitrary methods and attributes in template/game-server/app/servers/connector/handler/entryHandler.js because certain internal attributes can be overwritten via a conflicting name. Hence, a malicious attacker can manipulate internal attributes by adding additional attributes to user input.
NVD description
Pomelo v2.2.5 allows external control of critical state data. A malicious user input can corrupt arbitrary methods and attributes in template/game-server/app/servers/connector/handler/entryHandler.js because certain internal attributes can be overwritten via a conflicting name. Hence, a malicious attacker can manipulate internal attributes by adding additional attributes to user input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free