In short
- CVE-2019-19507 is a MEDIUM (CVSS 5.3) vulnerability affecting json pattern validator (json pattern validator project), jpv.
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 62.2% of all vulnerabilities.
- Fix: update to 2.1.1 or later.
Description
In jpv (aka Json Pattern Validator) before 2.1.1, compareCommon() can be bypassed because certain internal attributes can be overwritten via a conflicting name, as demonstrated by 'constructor': {'name':'Array'}. This affects validate(). Hence, a crafted payload can overwrite this builtin attribute to manipulate the type detection result.
NVD description
In jpv (aka Json Pattern Validator) before 2.1.1, compareCommon() can be bypassed because certain internal attributes can be overwritten via a conflicting name, as demonstrated by 'constructor': {'name':'Array'}. This affects validate(). Hence, a crafted payload can overwrite this builtin attribute to manipulate the type detection result.
More vulnerabilities in json pattern validator
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free