In short
- CVE-2019-19588 is a HIGH (CVSS 7.5) vulnerability affecting validators, validators (validators project).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 73.8% of all vulnerabilities.
- Fix: update to 0.12.6 or later.
| Package | Affected versions | Patched versions |
|---|
| validators PyPI | ≥ 0.12.2, < 0.12.6
| 0.12.6
|
| validators | ≥ 0.12.2, ≤ 0.12.5
| No fix yet |
Description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
NVD description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free