In short
- CVE-2019-20477 is a CRITICAL (CVSS 9.8) vulnerability affecting pyyaml, pyyaml (pyyaml).
- Chance of exploitation in the next 30 days (EPSS): 5.1%, higher than 92.4% of all vulnerabilities.
- Fix: update to 5.2, 5.2b1 or later.
| Package | Affected versions | Patched versions |
|---|
| pyyaml PyPI | ≥ 5.1, < 5.2≥ 5.1, < 5.2b1
| 5.25.2b1
|
| pyyaml | ≥ 5.1, ≤ 5.1.2
| No fix yet |
Description
PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.
NVD description
PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g., Popen is a class in the subprocess module. NOTE: this issue exists because of an incomplete fix for CVE-2017-18342.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free