In short
- CVE-2019-20920 is a HIGH (CVSS 8.1) vulnerability affecting handlebars (handlebarsjs), handlebars.
- Chance of exploitation in the next 30 days (EPSS): 3.2%, higher than 88.0% of all vulnerabilities.
- Fix: update to 4.5.3, 3.0.8 or later.
| Package | Affected versions | Patched versions |
|---|
| handlebars | ≥ 4.0.0, < 4.5.3< 3.0.8
| 4.5.33.0.8
|
| handlebars npm | ≥ 4.0.0, < 4.5.3< 3.0.8
| 4.5.33.0.8
|
Description
Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).
NVD description
Handlebars before 3.0.8 and 4.x before 4.5.3 is vulnerable to Arbitrary Code Execution. The lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript. This can be used to run arbitrary code on a server processing Handlebars templates or in a victim's browser (effectively serving as XSS).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free