In short
- CVE-2019-20922 is a HIGH (CVSS 7.5) vulnerability affecting handlebars (handlebarsjs), handlebars.
- Chance of exploitation in the next 30 days (EPSS): 3.7%, higher than 89.7% of all vulnerabilities.
- Fix: update to 4.4.5 or later.
| Package | Affected versions | Patched versions |
|---|
| handlebars | ≥ 4.0.0, < 4.4.5
| 4.4.5
|
| handlebars npm | ≥ 4.0.0, < 4.4.5
| 4.4.5
|
Description
Handlebars before 4.4.5 allows Regular Expression Denial of Service (ReDoS) because of eager matching. The parser may be forced into an endless loop while processing crafted templates. This may allow attackers to exhaust system resources.
NVD description
Handlebars before 4.4.5 allows Regular Expression Denial of Service (ReDoS) because of eager matching. The parser may be forced into an endless loop while processing crafted templates. This may allow attackers to exhaust system resources.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free