In short
- CVE-2019-2391 is a MEDIUM (CVSS 5.4) vulnerability affecting js-bson (mongodb), bson.
- Chance of exploitation in the next 30 days (EPSS): 0.77%, higher than 55.5% of all vulnerabilities.
- Fix: update to 1.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| js-bson | < 1.1.4
| 1.1.4
|
| bson npm | < 1.1.4
| 1.1.4
|
Description
Incorrect parsing of certain JSON input may result in js-bson not correctly serializing BSON. This may cause unexpected application behaviour including data disclosure.
NVD description
Incorrect parsing of certain JSON input may result in js-bson not correctly serializing BSON. This may cause unexpected application behaviour including data disclosure. This issue affects: MongoDB Inc. js-bson library version 1.1.3 and prior to.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free