In short
- CVE-2019-25060 is a MEDIUM (CVSS 5.3) vulnerability affecting wp-graphql/wp-graphql, wpgraphql (wpgraphql).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.8% of all vulnerabilities.
- Fix: update to 0.3.5 or later.
Description
The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.
NVD description
The WPGraphQL WordPress plugin before 0.3.5 doesn't properly restrict access to information about other users' roles on the affected site. Because of this, a remote attacker could forge a GraphQL query to retrieve the account roles of every user on the site.
More vulnerabilities in wp-graphql/wp-graphql
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free