In short
- CVE-2019-25091 is a MEDIUM (CVSS 5.3) vulnerability affecting nsupdate, nsupdate.info (nsupdate).
- Chance of exploitation in the next 30 days (EPSS): 0.67%, higher than 52.2% of all vulnerabilities.
- Fix: update to 0.13.0, 2019-05-19 or later.
| Package | Affected versions | Patched versions |
|---|
| nsupdate PyPI | ≤ 0.12.0< 0.13.0
| 0.13.0
|
| nsupdate.info | < 2019-05-19
| 2019-05-19
|
Description
A vulnerability classified as problematic has been found in nsupdate.info. This affects an unknown part of the file src/nsupdate/settings/base.py of the component CSRF Cookie Handler. The manipulation of the argument CSRF_COOKIE_HTTPONLY leads to cookie without httponly flag. It is possible to initiate the attack remotely. The name of the patch is 60a3fe559c453bc36b0ec3e5dd39c1303640a59a. It is recommended to apply a patch to fix this issue. The identifier VDB-216909 was assigned to this vulnerability.
NVD description
A vulnerability classified as problematic has been found in nsupdate.info. This affects an unknown part of the file src/nsupdate/settings/base.py of the component CSRF Cookie Handler. The manipulation of the argument CSRF_COOKIE_HTTPONLY leads to cookie without 'httponly' flag. It is possible to initiate the attack remotely. The name of the patch is 60a3fe559c453bc36b0ec3e5dd39c1303640a59a. It is recommended to apply a patch to fix this issue. The identifier VDB-216909 was assigned to this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free