In short
- CVE-2019-25101 is a CRITICAL (CVSS 9.8) vulnerability affecting turbogears, turbogears (turbogears project).
- Chance of exploitation in the next 30 days (EPSS): 0.86%, higher than 58.8% of all vulnerabilities.
- Fix: update to 1.0.11.11 or later.
| Package | Affected versions | Patched versions |
|---|
| turbogears PyPI | < 1.0.11.11
| 1.0.11.11
|
| turbogears | = 1.0.11.10
| No fix yet |
Description
A vulnerability classified as critical has been found in OnShift TurboGears 1.0.11.10. This affects an unknown part of the file turbogears/controllers.py of the component HTTP Header Handler. The manipulation leads to http response splitting. It is possible to initiate the attack remotely. Upgrading to version 1.0.11.11 is able to address this issue. The name of the patch is f68bbaba47f4474e1da553aa51564a73e1d92a84. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220059.
NVD description
A vulnerability classified as critical has been found in OnShift TurboGears 1.0.11.10. This affects an unknown part of the file turbogears/controllers.py of the component HTTP Header Handler. The manipulation leads to http response splitting. It is possible to initiate the attack remotely. Upgrading to version 1.0.11.11 is able to address this issue. The patch is named f68bbaba47f4474e1da553aa51564a73e1d92a84. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220059.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free