In short
- CVE-2019-25103 is a HIGH (CVSS 7.5) vulnerability affecting simple-markdown (khanacademy), simple-markdown.
- Chance of exploitation in the next 30 days (EPSS): 0.94%, higher than 61.1% of all vulnerabilities.
- Fix: update to 0.5.2 or later.
Description
A vulnerability has been found in simple-markdown 0.5.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file simple-markdown.js. The manipulation leads to inefficient regular expression complexity. The attack can be launched remotely. Upgrading to version 0.5.2 is able to address this issue. The name of the patch is 89797fef9abb4cab2fb76a335968266a92588816. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220639.
NVD description
A vulnerability has been found in simple-markdown 0.5.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file simple-markdown.js. The manipulation leads to inefficient regular expression complexity. The attack can be launched remotely. Upgrading to version 0.5.2 is able to address this issue. The patch is named 89797fef9abb4cab2fb76a335968266a92588816. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-220639.
More vulnerabilities in simple-markdown
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free