In short
- CVE-2019-3564 is a HIGH (CVSS 7.5) vulnerability affecting github.com/facebook/fbthrift, thrift (facebook).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.7% of all vulnerabilities.
- Fix: update to 0.31.1-0.20190225164308-c461c1bd1a3e, 2019.03.04.00 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/facebook/fbthrift Go | < 0.31.1-0.20190225164308-c461c1bd1a3e
| 0.31.1-0.20190225164308-c461c1bd1a3e
|
| thrift | < 2019.03.04.00
| 2019.03.04.00
|
Description
Go Facebook Thrift servers would not error upon receiving messages with containers of fields of unknown type. As a result, malicious clients could send short messages which would take a long time for the server to parse, potentially leading to denial of service. This issue affects Facebook Thrift prior to v2019.03.04.00.
NVD description
Go Facebook Thrift servers would not error upon receiving messages with containers of fields of unknown type. As a result, malicious clients could send short messages which would take a long time for the server to parse, potentially leading to denial of service. This issue affects Facebook Thrift prior to v2019.03.04.00.
More vulnerabilities in github.com/facebook/fbthrift
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free