In short
- CVE-2019-3848 is a MEDIUM (CVSS 4.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.92%, higher than 60.3% of all vulnerabilities.
- Fix: update to 3.4.8, 3.5.5, 3.6.3 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.4, < 3.4.8≥ 3.5, < 3.5.5≥ 3.6, < 3.6.3
| 3.4.83.5.53.6.3
|
| moodle | ≥ 3.5.0, < 3.5.5≥ 3.6.0, < 3.6.3< 3.4.8
| 3.5.53.6.33.4.8
|
Description
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)
NVD description
A vulnerability was found in moodle before versions 3.6.3, 3.5.5 and 3.4.8. Permissions were not correctly checked before loading event information into the calendar's edit event modal popup, so logged in non-guest users could view unauthorised calendar events. (Note: It was read-only access, users could not edit the events.)
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free