In short
- CVE-2019-7537 is a CRITICAL (CVSS 9.8) vulnerability affecting donfig, donfig (pytroll).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 89.1% of all vulnerabilities.
- Fix: update to 0.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| donfig PyPI | < 0.4.0
| 0.4.0
|
| donfig | = 0.3.0
| No fix yet |
Description
An issue was discovered in Donfig 0.3.0. There is a vulnerability in the collect_yaml method in config_obj.py. It can execute arbitrary Python commands, resulting in command execution.
NVD description
An issue was discovered in Donfig 0.3.0. There is a vulnerability in the collect_yaml method in config_obj.py. It can execute arbitrary Python commands, resulting in command execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free