In short
- CVE-2019-7872 is a MEDIUM (CVSS 6.5) vulnerability affecting magento/community-edition, magento (magento).
- Chance of exploitation in the next 30 days (EPSS): 0.90%, higher than 59.6% of all vulnerabilities.
- Fix: update to 2.1.18, 2.2.9, 2.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| magento/community-edition Packagist | ≥ 2.1, < 2.1.18≥ 2.2, < 2.2.9≥ 2.3, < 2.3.2
| 2.1.182.2.92.3.2
|
| magento | ≥ 2.1.0, < 2.1.18≥ 2.2.0, < 2.2.9≥ 2.3.0, < 2.3.2
| 2.1.182.2.92.3.2
|
Description
An insecure direct object reference (IDOR) vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 due to insufficient authorizations checks. This can be abused by a user with admin privileges to add users to company accounts or modify existing user details.
NVD description
An insecure direct object reference (IDOR) vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2 due to insufficient authorizations checks. This can be abused by a user with admin privileges to add users to company accounts or modify existing user details.
More vulnerabilities in magento/community-edition
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free