In short
- CVE-2019-7930 is a HIGH (CVSS 7.2) vulnerability affecting magento/community-edition, magento (magento).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.2% of all vulnerabilities.
- Fix: update to 2.1.18, 2.2.9, 2.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| magento/community-edition Packagist | ≥ 2.1, < 2.1.18≥ 2.2, < 2.2.9≥ 2.3, < 2.3.2
| 2.1.182.2.92.3.2
|
| magento | ≥ 2.1.0, < 2.1.18≥ 2.2.0, < 2.2.9≥ 2.3.0, < 2.3.2
| 2.1.182.2.92.3.2
|
Description
A file upload restriction bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with administrator privileges to the import feature can make modifications to a configuration file, resulting in potentially unauthorized removal of file upload restrictions. This can result in arbitrary code execution when a malicious file is then uploaded and executed on the system.
NVD description
A file upload restriction bypass exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with administrator privileges to the import feature can make modifications to a configuration file, resulting in potentially unauthorized removal of file upload restrictions. This can result in arbitrary code execution when a malicious file is then uploaded and executed on the system.
More vulnerabilities in magento/community-edition
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free