In short
- CVE-2019-8119 is a HIGH (CVSS 7.2) vulnerability affecting magento/community-edition, magento (magento).
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.1% of all vulnerabilities.
- Fix: update to 2.1.19, 2.2.10, 2.3.3 or later.
| Package | Affected versions | Patched versions |
|---|
| magento/community-edition Packagist | ≥ 2.1.0, < 2.1.19≥ 2.2.0, < 2.2.10≥ 2.3.0, < 2.3.3
| 2.1.192.2.102.3.3
|
| magento | ≥ 2.1.0, < 2.1.19≥ 2.2.0, < 2.2.10≥ 2.3.0, ≤ 2.3.2
| 2.1.192.2.10
|
Description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated admin user with import product privileges can delete files through bulk product import and inject code into XSLT file. The combination of these manipulations can lead to remote code execution.
NVD description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated admin user with import product privileges can delete files through bulk product import and inject code into XSLT file. The combination of these manipulations can lead to remote code execution.
More vulnerabilities in magento/community-edition
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free