In short
- CVE-2019-8120 is a MEDIUM (CVSS 5.4) vulnerability affecting magento/community-edition, magento (magento).
- Chance of exploitation in the next 30 days (EPSS): 0.56%, higher than 46.4% of all vulnerabilities.
- Fix: update to 2.1.19, 2.2.10, 2.3.3 or later.
| Package | Affected versions | Patched versions |
|---|
| magento/community-edition Packagist | ≥ 2.1.0, < 2.1.19≥ 2.2.0, < 2.2.10≥ 2.3.0, < 2.3.3
| 2.1.192.2.102.3.3
|
| magento | ≥ 2.1.0, < 2.1.19≥ 2.2.0, < 2.2.10≥ 2.3.0, ≤ 2.3.2
| 2.1.192.2.10
|
Description
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user can inject arbitrary Javascript code by manipulating section of a POST request related to customer's email address.
NVD description
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user can inject arbitrary Javascript code by manipulating section of a POST request related to customer's email address.
More vulnerabilities in magento/community-edition
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free