In short
- CVE-2019-8325 is a HIGH (CVSS 7.5) vulnerability affecting rubygems-update, rubygems (rubygems).
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.4% of all vulnerabilities.
- Fix: update to 2.7.9, 3.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| rubygems-update RubyGems | ≥ 2.6.0, < 2.7.9≥ 3.0.0, < 3.0.2
| 2.7.93.0.2
|
| rubygems | ≥ 2.6.0, ≤ 3.0.2
| No fix yet |
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)
NVD description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)
More vulnerabilities in rubygems-update
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free