In short
- CVE-2019-9901 is a CRITICAL (CVSS 10.0) vulnerability affecting github.com/envoyproxy/envoy, envoy (envoyproxy).
- Chance of exploitation in the next 30 days (EPSS): 5.0%, higher than 92.2% of all vulnerabilities.
- Fix: update to 1.9.1 or later.
Description
Envoy 1.9.0 and before does not normalize HTTP URL paths. A remote attacker may craft a relative path, e.g., something/../admin, to bypass access control, e.g., a block on /admin. A backend server could then interpret the non-normalized path and provide an attacker access beyond the scope provided for by the access control policy.
NVD description
Envoy 1.9.0 and before does not normalize HTTP URL paths. A remote attacker may craft a relative path, e.g., something/../admin, to bypass access control, e.g., a block on /admin. A backend server could then interpret the non-normalized path and provide an attacker access beyond the scope provided for by the access control policy.
More vulnerabilities in github.com/envoyproxy/envoy
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free