In short
- CVE-2020-10109 is a CRITICAL (CVSS 9.8) vulnerability affecting twisted, twisted (twisted).
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.5% of all vulnerabilities.
- Fix: update to 20.3.0, 20.3.0rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| twisted PyPI | < 20.3.0< 20.3.0rc1
| 20.3.020.3.0rc1
|
| twisted | ≤ 19.10.0
| No fix yet |
Description
In Twisted Web through 20.3.0, there was an HTTP request splitting vulnerability. When presented with a content-length and a chunked encoding header, the content-length took precedence and the remainder of the request body was interpreted as a pipelined request.
NVD description
In Twisted Web through 19.10.0, there was an HTTP request splitting vulnerability. When presented with a content-length and a chunked encoding header, the content-length took precedence and the remainder of the request body was interpreted as a pipelined request.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free