| Package | Affected versions | Patched versions |
|---|---|---|
| tortoise-orm | ≥ 0.16.0, < 0.16.6< 0.15.23 | 0.16.60.15.23 |
| tortoise orm | ≥ 0.16.0, < 0.16.6< 0.15.23 | 0.16.60.15.23 |
Various forms of SQL injection has been found, for MySQL and when filtering or doing mass-updates on char/text fields.
SQLite & PostgreSQL was only affected when filtering with contains, starts_with or ends_with filters (and their case-insensitive counterparts)
Please upgrade to 0.15.23+ or 0.16.6+
If you have any questions or comments about this advisory:
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free