In short
- CVE-2020-11979 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.ant:ant, ant (apache), gradle (gradle).
- Chance of exploitation in the next 30 days (EPSS): 7.8%, higher than 94.6% of all vulnerabilities.
- Fix: update to 1.10.9, 6.8.0, 11.2.2.8.27 or later.
Description
As mitigation for CVE-2020-1945 Apache Ant 1.10.8 changed the permissions of temporary files it created so that only the current user was allowed to access them. Unfortunately the fixcrlf task deleted the temporary file and created a new one without said protection, effectively nullifying the effort. This would still allow an attacker to inject modified source files into the build process.
NVD description
As mitigation for CVE-2020-1945 Apache Ant 1.10.8 changed the permissions of temporary files it created so that only the current user was allowed to access them. Unfortunately the fixcrlf task deleted the temporary file and created a new one without said protection, effectively nullifying the effort. This would still allow an attacker to inject modified source files into the build process.
More vulnerabilities in org.apache.ant:ant
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free