In short
- CVE-2020-11982 is a CRITICAL (CVSS 9.8) vulnerability affecting apache-airflow, airflow (apache).
- Chance of exploitation in the next 30 days (EPSS): 7.2%, higher than 94.3% of all vulnerabilities.
- Fix: update to 1.10.11, 1.10.11rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | < 1.10.11< 1.10.11rc1
| 1.10.111.10.11rc1
|
| airflow | ≤ 1.10.10
| No fix yet |
Description
An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.
NVD description
An issue was found in Apache Airflow versions 1.10.10 and below. When using CeleryExecutor, if an attack can connect to the broker (Redis, RabbitMQ) directly, it was possible to insert a malicious payload directly to the broker which could lead to a deserialization attack (and thus remote code execution) on the Worker.
More vulnerabilities in apache-airflow
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free