In short
- CVE-2020-13091 is a CRITICAL (CVSS 9.8) vulnerability affecting pandas, pandas (numfocus).
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.3% of all vulnerabilities.
- Fix: update to 1.0.4 or later.
| Package | Affected versions | Patched versions |
|---|
| pandas PyPI | < 1.0.4
| 1.0.4
|
| pandas | ≤ 1.0.3
| No fix yet |
Description
** DISPUTED ** pandas through 1.0.3 can unserialize and execute commands from an untrusted file that is passed to the read_pickle() function, if reduce makes an os.system call. NOTE: third parties dispute this issue because the read_pickle() function is documented as unsafe and it is the user's responsibility to use the function in a secure manner.
NVD description
pandas through 1.0.3 can unserialize and execute commands from an untrusted file that is passed to the read_pickle() function, if __reduce__ makes an os.system call. NOTE: third parties dispute this issue because the read_pickle() function is documented as unsafe and it is the user's responsibility to use the function in a secure manner
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free