In short
- CVE-2020-13757 is a HIGH (CVSS 7.5) vulnerability affecting rsa, python-rsa (python-rsa project).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 73.1% of all vulnerabilities.
- Fix: update to 4.1 or later.
| Package | Affected versions | Patched versions |
|---|
| rsa PyPI | < 4.1
| 4.1
|
| python-rsa | < 4.1
| 4.1
|
Description
Python-RSA before 4.1 ignores leading '\0' bytes during decryption of ciphertext. This could conceivably have a security-relevant impact, e.g., by helping an attacker to infer that an application uses Python-RSA, or if the length of accepted ciphertext affects application behavior (such as by causing excessive memory allocation).
NVD description
Python-RSA before 4.1 ignores leading '\0' bytes during decryption of ciphertext. This could conceivably have a security-relevant impact, e.g., by helping an attacker to infer that an application uses Python-RSA, or if the length of accepted ciphertext affects application behavior (such as by causing excessive memory allocation).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free