| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.solr:solr-core | ≥ 6.6.0, < 8.6.3 | 8.6.3 |
| org.apache.solr:solr-parent | ≥ 6.6.0, < 8.6.3 | 8.6.3 |
| org.apache.solr:solr-solrj | ≥ 6.6.0, < 8.6.3 | 8.6.3 |
| solr | ≥ 6.6.0, ≤ 6.6.6≥ 7.0.0, ≤ 7.7.3≥ 8.0.0, ≤ 8.6.2 |
Apache Solr versions 6.6.0 to 6.6.6, 7.0.0 to 7.7.3 and 8.0.0 to 8.6.2 prevents some features considered dangerous (which could be used for remote code execution) to be configured in a ConfigSet that's uploaded via API without authentication/authorization. The checks in place to prevent such features can be circumvented by using a combination of UPLOAD/CREATE actions. This issue is patched in 8.6.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free