In short
- CVE-2020-14144 is a HIGH (CVSS 7.2) vulnerability affecting code.gitea.io/gitea, gitea (gitea).
- Chance of exploitation in the next 30 days (EPSS): 95.4%, higher than 99.9% of all vulnerabilities.
- Fix: update to 1.12.6 or later.
Description
The git hook feature in Gitea 1.1.0 through 1.12.5 allows for authenticated remote code execution.
NVD description
The git hook feature in Gitea 1.1.0 through 1.12.5 might allow for authenticated remote code execution in customer environments where the documentation was not understood (e.g., one viewpoint is that the dangerousness of this feature should be documented immediately above the ENABLE_GIT_HOOKS line in the config file). NOTE: The vendor has indicated this is not a vulnerability and states "This is a functionality of the software that is limited to a very limited subset of accounts. If you give someone the privilege to execute arbitrary code on your server, they can execute arbitrary code on your server. We provide very clear warnings to users around this functionality and what it provides.
More vulnerabilities in code.gitea.io/gitea
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free