In short
- CVE-2020-15095 is a MEDIUM (CVSS 4.4) vulnerability affecting npm (npmjs), npm.
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 34.6% of all vulnerabilities.
- Fix: update to 6.14.6 or later.
| Package | Affected versions | Patched versions |
|---|
| npm | < 6.14.6
| 6.14.6
|
| npm npm | < 6.14.6
| 6.14.6
|
Description
Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like <protocol>://[<user>[:<password>]@]<hostname>[:<port>][:][/]<path>. The password value is not redacted and is printed to stdout and also to any generated log files.
NVD description
Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files. The CLI supports URLs like "<protocol>://[<user>[:<password>]@]<hostname>[:<port>][:][/]<path>". The password value is not redacted and is printed to stdout and also to any generated log files.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free