In short
- CVE-2020-15159 is a HIGH (CVSS 7.6) vulnerability affecting baserproject/basercms, basercms (basercms).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.2% of all vulnerabilities.
- Fix: update to 4.3.7 or later.
Description
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) and Remote Code Execution (RCE).
- Impact: XSS to RCE via Arbitrary file upload.
- Attack vector is: Administrator must be logged in.
- Components are: ThemeFilesController.php, UploaderFilesController.php.
- Tested baserCMS Version : 4.3.6 (Latest)
- Affected baserCMS Version : 4.2.0 ~ 4.3.6 (XSS), 3.0.10 ~ 4.3.6 (RCE)
- Patches : https://basercms.net/security/20200827
Found by Vulnerability Research team in Flatt Security Inc.
NVD description
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) and Remote Code Execution (RCE). This may be executed by logging in as a system administrator and uploading an executable script file such as a PHP file.The affected components are ThemeFilesController.php and UploaderFilesController.php. This is fixed in version 4.3.7.
More vulnerabilities in baserproject/basercms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free