In short
- CVE-2020-15391 is a CRITICAL (CVSS 9.8) vulnerability affecting github.com/loft-sh/devspace, devspace (devspace).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 86.1% of all vulnerabilities.
- Fix: update to 4.14.0 or later.
Description
The UI in DevSpace 4.13.0 allows web sites to execute actions on pods (on behalf of a victim) because of a lack of authentication for the WebSocket protocol. This leads to remote code execution.
NVD description
The UI in DevSpace 4.13.0 allows web sites to execute actions on pods (on behalf of a victim) because of a lack of authentication for the WebSocket protocol. This leads to remote code execution.
More vulnerabilities in github.com/loft-sh/devspace
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free