In short
- CVE-2020-15703 is a LOW (CVSS 3.3) vulnerability affecting aptdaemon, aptdaemon (aptdaemon project).
- Chance of exploitation in the next 30 days (EPSS): 0.49%, higher than 42.3% of all vulnerabilities.
- Fix: update to 1.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| aptdaemon PyPI | < 1.1.1
| 1.1.1
|
| aptdaemon | = 1.1.1
| No fix yet |
Description
There is no input validation on the Locale property in an apt transaction. An unprivileged user can supply a full path to a writable directory, which lets aptd read a file as root. Having a symlink in place results in an error message if the file exists, and no error otherwise. This way an unprivileged user can check for the existence of any files on the system as root.
NVD description
There is no input validation on the Locale property in an apt transaction. An unprivileged user can supply a full path to a writable directory, which lets aptd read a file as root. Having a symlink in place results in an error message if the file exists, and no error otherwise. This way an unprivileged user can check for the existence of any files on the system as root.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free