In short
- CVE-2020-15904 is a HIGH (CVSS 7.8) vulnerability affecting bsdiff4, bsdiff4 (pypi).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.3% of all vulnerabilities.
- Fix: update to 1.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| bsdiff4 PyPI | < 1.2.0
| 1.2.0
|
| bsdiff4 | < 1.2.0
| 1.2.0
|
Description
A buffer overflow in the patching routine of bsdiff4 before 1.2.0 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.
NVD description
A buffer overflow in the patching routine of bsdiff4 before 1.2.0 allows an attacker to write to heap memory (beyond allocated bounds) via a crafted patch file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free