In short
- CVE-2020-17446 is a CRITICAL (CVSS 9.8) vulnerability affecting asyncpg, asyncpg (magic).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.2% of all vulnerabilities.
- Fix: update to 0.21.0 or later.
| Package | Affected versions | Patched versions |
|---|
| asyncpg PyPI | < 0.21.0
| 0.21.0
|
| asyncpg | < 0.21.0
| 0.21.0
|
Description
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
NVD description
asyncpg before 0.21.0 allows a malicious PostgreSQL server to trigger a crash or execute arbitrary code (on a database client) via a crafted server response, because of access to an uninitialized pointer in the array data decoder.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free