In short
- CVE-2020-17516 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.cassandra:cassandra-all, cassandra (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.3% of all vulnerabilities.
- Fix: update to 3.0.24, 3.11.10 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.cassandra:cassandra-all Maven | ≥ 2.1.0, < 3.0.24≥ 3.11.0, < 3.11.10
| 3.0.243.11.10
|
| cassandra | ≥ 2.1.0, ≤ 2.1.22≥ 2.2.0, ≤ 2.2.19≥ 3.0.0, ≤ 3.0.23≥ 3.11.0, ≤ 3.11.9
| No fix yet |
Description
Apache Cassandra versions 2.1.0 to 2.1.22, 2.2.0 to 2.2.19, 3.0.0 to 3.0.23, and 3.11.0 to 3.11.9, when using 'dc' or 'rack' internode_encryption setting, allows both encrypted and unencrypted internode connections. A misconfigured node or a malicious user can use the unencrypted connection despite not being in the same rack or dc, and bypass mutual TLS requirement.
NVD description
Apache Cassandra versions 2.1.0 to 2.1.22, 2.2.0 to 2.2.19, 3.0.0 to 3.0.23, and 3.11.0 to 3.11.9, when using 'dc' or 'rack' internode_encryption setting, allows both encrypted and unencrypted internode connections. A misconfigured node or a malicious user can use the unencrypted connection despite not being in the same rack or dc, and bypass mutual TLS requirement.
More vulnerabilities in org.apache.cassandra:cassandra-all
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free