In short
- CVE-2020-1914 is a CRITICAL (CVSS 9.8) vulnerability affecting hermes (facebook), hermes-engine.
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 84.8% of all vulnerabilities.
- Fix: update to 2020-10-01, 0.7.2 or later.
| Package | Affected versions | Patched versions |
|---|
| hermes | < 2020-10-01
| 2020-10-01
|
| hermes-engine npm | < 0.7.2
| 0.7.2
|
Description
A logic vulnerability when handling the SaveGeneratorLong instruction in Facebook Hermes prior to commit b2021df620824627f5a8c96615edbd1eb7fdddfc allows attackers to potentially read out of bounds or theoretically execute arbitrary code via crafted JavaScript. Note that this is only exploitable if the application using Hermes permits evaluation of untrusted JavaScript. Hence, most React Native applications are not affected.
NVD description
A logic vulnerability when handling the SaveGeneratorLong instruction in Facebook Hermes prior to commit b2021df620824627f5a8c96615edbd1eb7fdddfc allows attackers to potentially read out of bounds or theoretically execute arbitrary code via crafted JavaScript. Note that this is only exploitable if the application using Hermes permits evaluation of untrusted JavaScript. Hence, most React Native applications are not affected.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free