Apache Tomcat Improper Privilege Management Vulnerability. Actively exploited: CISA added this vulnerability to its Known Exploited Vulnerabilities catalog on 03/03/2022. Patch affected systems as an emergency.
| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 7.0.0, < 7.0.100≥ 8.0.0, < 8.5.51≥ 9.0.0, < 9.0.31 | 7.0.1008.5.519.0.31 |
| geode | = 1.12.0 | |
| tomcat | ≥ 7.0.0, < 7.0.100≥ 8.5.0, < 8.5.51≥ 9.0.0, < 9.0.31 | 7.0.1008.5.519.0.31 |
| good control | ≤ 5.2.58.38 | |
| workspaces server | = 7.0.1= 7.1.2= 8.1.0= 9.0 | |
| oncommand system manager | ≥ 3.0.0, ≤ 3.1.3 | |
| agile engineering data management | = 6.2.1.0 | |
| agile product lifecycle management | = 9.3.3= 9.3.5= 9.3.6 | |
| communications element manager | = 8.1.1= 8.2.0= 8.2.1 | |
| communications instant messaging server | = 10.0.1.4.0 | |
| health sciences empirica inspections | = 1.0.1.2 | |
| health sciences empirica signal | = 7.3.3 | |
| hospitality guest access | = 4.2.0= 4.2.1 | |
| instantis enterprisetrack | ≥ 17.1, ≤ 17.3 | |
| mysql enterprise monitor | ≥ 8.0.0, ≤ 8.0.20≤ 4.0.12 | |
| siebel ui framework | ≤ 20.5 | |
| transportation management | = 6.3.7 | |
| workload manager | = 12.2.0.1= 18c= 19c |
When using the Apache JServ Protocol (AJP), care must be taken when trusting incoming connections to Apache Tomcat. Tomcat treats AJP connections as having higher trust than, for example, a similar HTTP connection. If such connections are available to an attacker, they can be exploited in ways that may be surprising. In Apache Tomcat 9.0.0.M1 to 9.0.0.30, 8.5.0 to 8.5.50 and 7.0.0 to 7.0.99, Tomcat shipped with an AJP Connector enabled by default that listened on all configured IP addresses. It was expected (and recommended in the security guide) that this Connector would be disabled if not required. This vulnerability report identified a mechanism that allowed: returning arbitrary files from anywhere in the web application, processing any file in the web application as a JSP Further, if the web application allowed file upload and stored those files within the web application (or the attacker was able to control the content of the web application by some other means) then this, along with the ability to process a file as a JSP, made remote code execution possible. It is important to note that mitigation is only required if an AJP port is accessible to untrusted users. Users wishing to take a defence-in-depth approach and block the vector that permits returning arbitrary files and execution as JSP may upgrade to Apache Tomcat 9.0.31, 8.5.51 or 7.0.100 or later. A number of changes were made to the default AJP Connector configuration in 9.0.31 to harden the default configuration. It is likely that users upgrading to 9.0.31, 8.5.51 or 7.0.100 or later will need to make small changes to their configurations.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free