In short
- CVE-2020-2109 is a HIGH (CVSS 8.8) vulnerability affecting org.jenkins-ci.plugins.workflow:workflow-cps, pipeline (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 69.5% of all vulnerabilities.
- Fix: update to 2.79 or later.
Description
Sandbox protection in Jenkins Pipeline: Groovy Plugin 2.78 and earlier can be circumvented through default parameter expressions in CPS-transformed methods.
NVD description
Sandbox protection in Jenkins Pipeline: Groovy Plugin 2.78 and earlier can be circumvented through default parameter expressions in CPS-transformed methods.
More vulnerabilities in org.jenkins-ci.plugins.workflow:workflow-cps
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free