In short
- CVE-2020-22083 is a CRITICAL (CVSS 9.8) vulnerability affecting jsonpickle, jsonpickle (jsonpickle project).
- Chance of exploitation in the next 30 days (EPSS): 6.6%, higher than 93.9% of all vulnerabilities.
- Fix: update to 1.4.2 or later.
| Package | Affected versions | Patched versions |
|---|
| jsonpickle PyPI | ≤ 1.4.2< 1.4.2
| 1.4.2
|
| jsonpickle | ≤ 1.4.1
| No fix yet |
Description
jsonpickle through 1.4.2 allows remote code execution during deserialization of a malicious payload through the decode() function. This CVE is disputed by the project author as intended functionality.
NVD description
jsonpickle through 1.4.1 allows remote code execution during deserialization of a malicious payload through the decode() function. Note: It has been argued that this is expected and clearly documented behaviour. pickle is known to be capable of causing arbitrary code execution, and must not be used with un-trusted data
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free