In short
- CVE-2020-25816 is a MEDIUM (CVSS 6.8) vulnerability affecting github.com/hashicorp/vault, vault (hashicorp).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.2% of all vulnerabilities.
- Fix: update to 1.5.4, 1.4.7 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 1.0.0, < 1.5.4≥ 1.0.0-beta1, < 1.5.4
| 1.5.4
|
| vault | ≥ 1.0.0, < 1.4.7≥ 1.5.0, < 1.5.4
| 1.4.71.5.4
|
Description
HashiCorp Vault and Vault Enterprise 1.0 before 1.5.4 have Incorrect Access Control.
NVD description
HashiCorp Vault and Vault Enterprise versions 1.0 and newer allowed leases created with a batch token to outlive their TTL because expiration time was not scheduled correctly. Fixed in 1.4.7 and 1.5.4.
More vulnerabilities in github.com/hashicorp/vault
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free