In short
- CVE-2020-26229 is a LOW (CVSS 3.7) vulnerability affecting typo3/cms, typo3/cms-core, typo3 (typo3).
- Chance of exploitation in the next 30 days (EPSS): 0.64%, higher than 50.9% of all vulnerabilities.
- Fix: update to 10.4.10 or later.
| Package | Affected versions | Patched versions |
|---|
| typo3/cms Packagist | ≥ 10.0.0, < 10.4.10
| 10.4.10
|
| typo3/cms-core Packagist | ≥ 10.0.0, < 10.4.10
| 10.4.10
|
| typo3 | ≥ 10.0.0, < 10.4.10
| 10.4.10
|
Description
Problem
It has been discovered that RSS widgets are susceptible to XML external entity processing.
This vulnerability is reasonable, but is theoretical - it was not possible to actually reproduce the vulnerability with current PHP versions of supported and maintained system distributions.
At least with libxml2 version 2.9, the processing of XML external entities is disabled per default - and cannot be exploited. Besides that, a valid backend user account is needed.
Solution
Update to TYPO3 version 10.4.10 that fixes the problem described.
NVD description
TYPO3 is an open source PHP based web content management system. In TYPO3 from version 10.4.0, and before version 10.4.10, RSS widgets are susceptible to XML external entity processing. This vulnerability is reasonable, but is theoretical - it was not possible to actually reproduce the vulnerability with current PHP versions of supported and maintained system distributions. At least with libxml2 version 2.9, the processing of XML external entities is disabled per default - and cannot be exploited. Besides that, a valid backend user account is needed. Update to TYPO3 version 10.4.10 to fix the problem described.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free