In short
- CVE-2020-26288 is a MEDIUM (CVSS 6.5) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 0.81%, higher than 56.8% of all vulnerabilities.
- Fix: update to 4.5.0 or later.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js.
In Parse Server before version 4.5.0, user passwords involved in LDAP authentication are stored in cleartext.
This is fixed in version 4.5.0 by stripping password after authentication to prevent cleartext password storage.
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. It is an npm package "parse-server". In Parse Server before version 4.5.0, user passwords involved in LDAP authentication are stored in cleartext. This is fixed in version 4.5.0 by stripping password after authentication to prevent cleartext password storage.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free