In short
- CVE-2020-27822 is a MEDIUM (CVSS 5.9) vulnerability affecting org.wildfly:wildfly-parent, wildfly (redhat).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.2% of all vulnerabilities.
- Fix: update to 21.0.2.Final, 22.0.0.Beta1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.wildfly:wildfly-parent Maven | ≥ 19.0.0.Final, < 21.0.2.Final≥ 22.0.0.Alpha1, < 22.0.0.Beta1
| 21.0.2.Final22.0.0.Beta1
|
| wildfly | = 19.0.0= 19.1.0= 20.0.0= 20.0.1= 21.0.0
| No fix yet |
Description
A flaw was found in Wildfly affecting versions 19.0.0.Final, 19.1.0.Final, 20.0.0.Final, 20.0.1.Final, and 21.0.0.Final. When an application uses the OpenTracing API's java-interceptors, there is a possibility of a memory leak. This flaw allows an attacker to impact the availability of the server. The highest threat from this vulnerability is to system availability.
NVD description
A flaw was found in Wildfly affecting versions 19.0.0.Final, 19.1.0.Final, 20.0.0.Final, 20.0.1.Final, and 21.0.0.Final. When an application uses the OpenTracing API's java-interceptors, there is a possibility of a memory leak. This flaw allows an attacker to impact the availability of the server. The highest threat from this vulnerability is to system availability.
More vulnerabilities in org.wildfly:wildfly-parent
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free