In short
- CVE-2020-28248 is a HIGH (CVSS 8.8) vulnerability affecting png-img (png-img project), png-img.
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.7% of all vulnerabilities.
- Fix: update to 3.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| png-img | < 3.1.0
| 3.1.0
|
| png-img npm | < 3.1.0
| 3.1.0
|
Description
An integer overflow in the PngImg::InitStorage_() function of png-img before 3.1.0 leads to an under-allocation of heap memory and subsequently an exploitable heap-based buffer overflow when loading a crafted PNG file.
NVD description
An integer overflow in the PngImg::InitStorage_() function of png-img before 3.1.0 leads to an under-allocation of heap memory and subsequently an exploitable heap-based buffer overflow when loading a crafted PNG file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free