In short
- CVE-2020-28468 is a CRITICAL (CVSS 9.8) vulnerability affecting pwntools, pwntools (pwntools project).
- Chance of exploitation in the next 30 days (EPSS): 4.4%, higher than 91.3% of all vulnerabilities.
- Fix: update to 4.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pwntools PyPI | < 4.3.1
| 4.3.1
|
| pwntools | < 4.3.1
| 4.3.1
|
Description
This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.
NVD description
This affects the package pwntools before 4.3.1. The shellcraft generator for affected versions of this module are vulnerable to Server-Side Template Injection (SSTI), which can lead to remote code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free