In short
- CVE-2020-28975 is a HIGH (CVSS 7.5) vulnerability affecting scikit-learn, scikit-learn (scikit-learn).
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.2% of all vulnerabilities.
- Fix: update to 1.0.1, 0.24.dev0 or later.
| Package | Affected versions | Patched versions |
|---|
| scikit-learn PyPI | ≥ 0.23.2, < 1.0.1< 0.24.dev0
| 1.0.10.24.dev0
|
| scikit-learn | ≥ 0.23.2, < 1.0.1
| 1.0.1
|
Description
svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model SVM (introduced via pickle, json, or any other model permanence standard) with a large value in the _n_support array.
NOTE: the scikit-learn vendor's position is that the behavior can only occur if the library's API is violated by an application that changes a private attribute.
NVD description
svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model SVM (introduced via pickle, json, or any other model permanence standard) with a large value in the _n_support array. NOTE: the scikit-learn vendor's position is that the behavior can only occur if the library's API is violated by an application that changes a private attribute.
More vulnerabilities in scikit-learn
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free