In short
- CVE-2020-29367 is a HIGH (CVSS 7.8) vulnerability affecting blosc2, c-blosc2 (blosc).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.3% of all vulnerabilities.
- Fix: update to 0.1.7 or later.
| Package | Affected versions | Patched versions |
|---|
| blosc2 PyPI | < 0.1.7all versions
| 0.1.7
|
| c-blosc2 | = 2.0.0
| No fix yet |
Description
blosc2.c in Blosc C-Blosc2 through 2.0.0.beta.5 has a heap-based buffer overflow when there is a lack of space to write compressed data.
NVD description
blosc2.c in Blosc C-Blosc2 through 2.0.0.beta.5 has a heap-based buffer overflow when there is a lack of space to write compressed data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free