In short
- CVE-2020-29556 is a MEDIUM (CVSS 5.5) vulnerability affecting getgrav/grav, grav cms (getgrav).
- Chance of exploitation in the next 30 days (EPSS): 0.98%, higher than 62.4% of all vulnerabilities.
- Fix: update to 1.6.30, 1.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| getgrav/grav Packagist | ≥ 1.7.0-beta.1, ≤ 1.7.0-rc.17< 1.6.30
| 1.6.30
|
| grav cms | = 1.7.0< 1.7.0
| 1.7.0
|
Description
The Backup functionality in Grav CMS through 1.7.0-rc.17 allows an authenticated attacker to read arbitrary local files on the underlying server by exploiting a path-traversal technique. (This vulnerability can also be exploited by an unauthenticated attacker due to a lack of CSRF protection.)
NVD description
The Backup functionality in Grav CMS through 1.7.0-rc.17 allows an authenticated attacker to read arbitrary local files on the underlying server by exploiting a path-traversal technique. (This vulnerability can also be exploited by an unauthenticated attacker due to a lack of CSRF protection.)
More vulnerabilities in getgrav/grav
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free