In short
- CVE-2020-35681 is a HIGH (CVSS 7.4) vulnerability affecting channels, channels (djangoproject).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 85.7% of all vulnerabilities.
- Fix: update to 3.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| channels PyPI | ≥ 3.0.0, < 3.0.3
| 3.0.3
|
| channels | ≥ 3.0.0, < 3.0.3
| 3.0.3
|
Description
Django Channels 3.x before 3.0.3 allows remote attackers to obtain sensitive information from a different request scope. The legacy channels.http.AsgiHandler class, used for handling HTTP type requests in an ASGI environment prior to Django 3.0, did not correctly separate request scopes in Channels 3.0. In many cases this would result in a crash but, with correct timing, responses could be sent to the wrong client, resulting in potential leakage of session identifiers and other sensitive data. Note that this affects only the legacy Channels provided class, and not Django's similar ASGIHandler, available from Django 3.0.
NVD description
Django Channels 3.x before 3.0.3 allows remote attackers to obtain sensitive information from a different request scope. The legacy channels.http.AsgiHandler class, used for handling HTTP type requests in an ASGI environment prior to Django 3.0, did not correctly separate request scopes in Channels 3.0. In many cases this would result in a crash but, with correct timing, responses could be sent to the wrong client, resulting in potential leakage of session identifiers and other sensitive data. Note that this affects only the legacy Channels provided class, and not Django's similar ASGIHandler, available from Django 3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free