In short
- CVE-2020-36321 is a HIGH (CVSS 7.5) vulnerability affecting com.vaadin:flow-server, flow (vaadin), vaadin (vaadin).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.5% of all vulnerabilities.
- Fix: update to 2.4.2, 5.0.0, 14.4.3, 18.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| com.vaadin:flow-server Maven | ≥ 2.0.0, < 2.4.2≥ 3.0.0, < 5.0.0
| 2.4.25.0.0
|
| flow | ≥ 2.0.0, < 2.4.2≥ 3.0.0, < 5.0.0
| 2.4.25.0.0
|
| vaadin | ≥ 14.0.0, < 14.4.3≥ 15.0.0, < 18.0.0
| 14.4.318.0.0
|
Description
Improper URL validation in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.4.1 (Vaadin 14.0.0 through 14.4.2), and 3.0 prior to 5.0 (Vaadin 15 prior to 18) allows attacker to request arbitrary files stored outside of intended frontend resources folder.
NVD description
Improper URL validation in development mode handler in com.vaadin:flow-server versions 2.0.0 through 2.4.1 (Vaadin 14.0.0 through 14.4.2), and 3.0 prior to 5.0 (Vaadin 15 prior to 18) allows attacker to request arbitrary files stored outside of intended frontend resources folder.
More vulnerabilities in com.vaadin:flow-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free